summaryrefslogtreecommitdiff
path: root/muse_qt4_evolution/midiplugins/filter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse_qt4_evolution/midiplugins/filter/CMakeLists.txt')
-rw-r--r--muse_qt4_evolution/midiplugins/filter/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/muse_qt4_evolution/midiplugins/filter/CMakeLists.txt b/muse_qt4_evolution/midiplugins/filter/CMakeLists.txt
new file mode 100644
index 00000000..7bdb8544
--- /dev/null
+++ b/muse_qt4_evolution/midiplugins/filter/CMakeLists.txt
@@ -0,0 +1,49 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+QT4_WRAP_CPP ( filter_mocs filtergui.h ctrlcombo.h )
+QT4_WRAP_UI ( filter_uis filtergui.ui )
+
+add_library ( filter SHARED
+ filter.cpp
+ filtergui.cpp
+ filtergui.h
+ ctrlcombo.cpp
+ ctrlcombo.h
+ ${filter_mocs}
+ ${filter_uis}
+ )
+
+target_link_libraries( filter
+ midiplugin awl
+ ${QT_LIBRARIES}
+ )
+
+# - tell cmake to name target filter.so instead of
+# libfilter.so
+# - use precompiled header files
+#
+set_target_properties ( filter
+ PROPERTIES PREFIX ""
+ COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
+ )
+
+install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/midiplugins/ filter )
+