summaryrefslogtreecommitdiff
path: root/muse2/synti/libsynti/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/libsynti/CMakeLists.txt')
-rw-r--r--muse2/synti/libsynti/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/muse2/synti/libsynti/CMakeLists.txt b/muse2/synti/libsynti/CMakeLists.txt
new file mode 100644
index 00000000..10154a93
--- /dev/null
+++ b/muse2/synti/libsynti/CMakeLists.txt
@@ -0,0 +1,40 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+include(${PROJECT_SOURCE_DIR}/pch.txt)
+
+add_library(synti
+ ${PROJECT_BINARY_DIR}/all-pic.h.pch
+ mess.cpp
+ # mess2.cpp
+ gui.cpp
+ mono.cpp
+ poly.cpp
+ # midievent.cpp
+ mpevent.cpp
+ )
+
+#
+# -fPIC is necessary for 64 bit systems
+#
+set_target_properties( synti
+ PROPERTIES COMPILE_FLAGS "-fPIC -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ )
+