summaryrefslogtreecommitdiff
path: root/muse2/synti/fluidsynth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/fluidsynth/Makefile.am')
-rw-r--r--muse2/synti/fluidsynth/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/muse2/synti/fluidsynth/Makefile.am b/muse2/synti/fluidsynth/Makefile.am
new file mode 100644
index 00000000..817c3cb5
--- /dev/null
+++ b/muse2/synti/fluidsynth/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/common.am
+include $(top_srcdir)/synti/synti-install.am
+
+AM_CXXFLAGS += -fPIC -O3 -ffast-math -fno-exceptions
+
+synthi_LTLIBRARIES = fluidsynth.la
+
+fluidsynth_la_SOURCES = fluidsynti.h fluidsynti.cpp \
+ fluidsynthgui.cpp fluidsynthgui.h \
+ fluidsynthguibase.ui
+
+nodist_fluidsynth_la_SOURCES = moc_fluidsynthgui.cpp
+
+fluidsynth_la_LIBADD = ../libsynti/libsynti.la -lfluidsynth
+fluidsynth_la_LDFLAGS = -module -avoid-version
+
+CLEANFILES = $(wildcard *.ui~)
+EXTRA_DIST = TODO README.txt
+