summaryrefslogtreecommitdiff
path: root/muse2/synti/fluid/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/fluid/CMakeLists.txt')
-rw-r--r--muse2/synti/fluid/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/muse2/synti/fluid/CMakeLists.txt b/muse2/synti/fluid/CMakeLists.txt
new file mode 100644
index 00000000..81cf1e18
--- /dev/null
+++ b/muse2/synti/fluid/CMakeLists.txt
@@ -0,0 +1,51 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+QT4_WRAP_CPP ( fluid_mocs fluidgui.h )
+# QT4_WRAP_UI ( fluid_uis fluidgui.ui )
+QT4_WRAP_UI3 ( fluid_uis fluidguibase.ui )
+
+add_library ( fluid SHARED
+ fluid.cpp
+ fluidgui.cpp
+ fluidgui.h
+ ${fluid_mocs}
+ ${fluid_uis}
+ )
+
+target_link_libraries( fluid synti )
+
+# - tell cmake to name target fluid.so instead of
+# libfluid.so
+# - use precompiled header files
+#
+set_target_properties ( fluid
+ PROPERTIES PREFIX ""
+ COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
+ LINK_FLAGS "-L${FLUID_LIBDIR} ${FLUID_LIB}"
+ )
+target_link_libraries(fluid
+ synti
+ ${QT_LIBRARIES}
+ ${FLUID_LIB}
+ )
+
+install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/synthi/ fluid )
+