summaryrefslogtreecommitdiff
path: root/muse2/plugins/doublechorus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/plugins/doublechorus/CMakeLists.txt')
-rw-r--r--muse2/plugins/doublechorus/CMakeLists.txt25
1 files changed, 23 insertions, 2 deletions
diff --git a/muse2/plugins/doublechorus/CMakeLists.txt b/muse2/plugins/doublechorus/CMakeLists.txt
index 35d2c42b..04ea864f 100644
--- a/muse2/plugins/doublechorus/CMakeLists.txt
+++ b/muse2/plugins/doublechorus/CMakeLists.txt
@@ -18,10 +18,26 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#=============================================================================
+##
+## List of source files to compile
+##
+file (GLOB doublechorus_source_files
+ doublechorus.cpp
+ doublechorusmodel.cpp
+ simplechorusmodel.cpp
+ )
+
+##
+## Define target
+##
add_library ( doublechorus SHARED
- doublechorus.cpp doublechorusmodel.cpp simplechorusmodel.cpp
+ ${doublechorus_source_files}
)
+
+##
+## Compilation flags and target name
+##
# tell cmake to name the target doublechorus.so instead of
# libdoublechorus.so
#
@@ -30,4 +46,9 @@ set_target_properties (doublechorus
#COMPILE_FLAGS "-O3"
)
-install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/plugins doublechorus)
+##
+## Install location
+##
+install( TARGETS doublechorus
+ DESTINATION ${MusE_PLUGINS_DIR}
+ )