summaryrefslogtreecommitdiff
path: root/muse2/grepmidi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/grepmidi/CMakeLists.txt')
-rw-r--r--muse2/grepmidi/CMakeLists.txt20
1 files changed, 18 insertions, 2 deletions
diff --git a/muse2/grepmidi/CMakeLists.txt b/muse2/grepmidi/CMakeLists.txt
index 55084217..ff607aca 100644
--- a/muse2/grepmidi/CMakeLists.txt
+++ b/muse2/grepmidi/CMakeLists.txt
@@ -18,7 +18,23 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#=============================================================================
-add_executable ( grepmidi grepmidi.cpp )
+##
+## List of source files to compile
+##
+file (GLOB grepmidi_source_files
+ grepmidi.cpp
+ )
-install_targets ( /bin grepmidi )
+##
+## Define target
+##
+add_executable ( grepmidi
+ ${grepmidi_source_files}
+ )
+##
+## Install location
+##
+install(TARGETS grepmidi
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+ )