summaryrefslogtreecommitdiff
path: root/muse_qt4_evolution/synti/simpledrums/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Jonsson <spamatica@gmail.com>2011-03-07 19:01:11 +0000
committerRobert Jonsson <spamatica@gmail.com>2011-03-07 19:01:11 +0000
commite40fc849149dd97c248866a4a1d026dda5e57b62 (patch)
treeb12b358f3b3a0608001d30403358f8443118ec5f /muse_qt4_evolution/synti/simpledrums/CMakeLists.txt
parent1bd4f2e8d9745cabb667b043171cad22c8577768 (diff)
clean3
Diffstat (limited to 'muse_qt4_evolution/synti/simpledrums/CMakeLists.txt')
-rw-r--r--muse_qt4_evolution/synti/simpledrums/CMakeLists.txt52
1 files changed, 0 insertions, 52 deletions
diff --git a/muse_qt4_evolution/synti/simpledrums/CMakeLists.txt b/muse_qt4_evolution/synti/simpledrums/CMakeLists.txt
deleted file mode 100644
index b29bab02..00000000
--- a/muse_qt4_evolution/synti/simpledrums/CMakeLists.txt
+++ /dev/null
@@ -1,52 +0,0 @@
-#=============================================================================
-# MusE
-# Linux Music Editor
-# $Id:$
-#
-# Copyright (C) 2002-2006 by Werner Schweer and others
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#=============================================================================
-
-QT4_WRAP_CPP ( simpledrums_mocs simpledrumsgui.h ssplugingui.h )
-QT4_WRAP_UI ( simpledrums_uis simpledrumsguibase.ui sspluginchooserbase.ui )
-
-add_library ( simpledrums SHARED
- simpledrums.cpp
- simpledrumsgui.cpp
- simpledrums.h
- ssplugin.cpp
- ssplugingui.cpp
- ssplugin.h
- common.h
- ${simpledrums_mocs}
- ${simpledrums_uis}
- )
-
-# - tell cmake to name target simpledrums.so instead of
-# libsimpledrums.so
-# - use precompiled header files
-#
-set_target_properties ( simpledrums
- PROPERTIES PREFIX ""
- COMPILE_FLAGS "-O6 -include ${PROJECT_BINARY_DIR}/all-pic.h"
- )
-
-target_link_libraries(simpledrums
- synti
-# awl
- ${QT_LIBRARIES}
- )
-
-install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/synthi/ simpledrums )
-