summaryrefslogtreecommitdiff
path: root/muse2/synti/simpledrums2/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Jung <flo@windfisch.org>2012-03-15 18:21:23 +0000
committerFlorian Jung <flo@windfisch.org>2012-03-15 18:21:23 +0000
commit27b7bf6815cda7abb67026c37b3e44daee1803cb (patch)
tree0b9d1c0bc84ac7ff8032e707f2b5fb4e0aaabb5c /muse2/synti/simpledrums2/CMakeLists.txt
parent2d6f113a10eb485694e20a78500f650776d701e3 (diff)
merged with trunk
Diffstat (limited to 'muse2/synti/simpledrums2/CMakeLists.txt')
-rw-r--r--muse2/synti/simpledrums2/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/muse2/synti/simpledrums2/CMakeLists.txt b/muse2/synti/simpledrums2/CMakeLists.txt
index bf0c33d8..172ce616 100644
--- a/muse2/synti/simpledrums2/CMakeLists.txt
+++ b/muse2/synti/simpledrums2/CMakeLists.txt
@@ -74,9 +74,14 @@ set (FILES_TO_TRANSLATE
# libsimpledrums.so
# - use precompiled header files
#
+
+if ( x${CMAKE_BUILD_TYPE} STREQUAL xrelease )
+ SET(SIMPLEDRUMS_OPTFLAGS "-O6")
+endif ( x${CMAKE_BUILD_TYPE} STREQUAL xrelease )
+
set_target_properties ( simpledrums
PROPERTIES PREFIX ""
- COMPILE_FLAGS "-O6 -fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ COMPILE_FLAGS "${SIMPLEDRUMS_OPTFLAGS} -fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
)
##