summaryrefslogtreecommitdiff
path: root/muse2/synti/fluidsynth/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Jung <flo@windfisch.org>2011-12-21 17:39:57 +0000
committerFlorian Jung <flo@windfisch.org>2011-12-21 17:39:57 +0000
commit1057d7190242cdf9248671b316a398db805f5f56 (patch)
treeab50268a7db2f80cfb45a7ad6578fe735ab84ce5 /muse2/synti/fluidsynth/CMakeLists.txt
parent9977c7114089b8708d310268833b83343caa0fd1 (diff)
parentc36a5508aa42e596b005425208054af9a60734b4 (diff)
merged with trunk (that is, pulled the fixes from release_2_0)
only quickly tested, seems okay on the first glance
Diffstat (limited to 'muse2/synti/fluidsynth/CMakeLists.txt')
-rw-r--r--muse2/synti/fluidsynth/CMakeLists.txt16
1 files changed, 5 insertions, 11 deletions
diff --git a/muse2/synti/fluidsynth/CMakeLists.txt b/muse2/synti/fluidsynth/CMakeLists.txt
index db96341f..8ac178be 100644
--- a/muse2/synti/fluidsynth/CMakeLists.txt
+++ b/muse2/synti/fluidsynth/CMakeLists.txt
@@ -54,7 +54,7 @@ file (GLOB fluidsynth_source_files
##
## Define target
##
-add_library ( fluidsynth SHARED
+add_library ( fluid_synth SHARED
${fluidsynth_source_files}
${fluidsynth_mocs}
${fluidsynth_uis}
@@ -78,30 +78,24 @@ set (FILES_TO_TRANSLATE
# libfluidsynth.so
# - use precompiled header files
#
-set_target_properties ( fluidsynth
+set_target_properties ( fluid_synth
PROPERTIES PREFIX ""
COMPILE_FLAGS "-fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
- LINK_FLAGS "${FLUIDSYN_LDFLAGS}" # "-lfluidsynth"
)
-
##
## Linkage
##
-target_link_libraries(fluidsynth
+target_link_libraries(fluid_synth
synti
${QT_LIBRARIES}
- # Can't do this here, since FLUIDSYN_LIBRARIES evaluates
- # to 'fluidsynth', the same name as our target.
- # ${FLUIDSYN_LIBRARIES}
- # Try giving full path: Nope, path is empty!
- #${FLUIDSYN_LIBRARY_DIRS}/${FLUIDSYN_LIBRARIES}
+ ${FLUIDSYN_LIBRARIES}
)
##
## Install location
##
-install( TARGETS fluidsynth
+install( TARGETS fluid_synth
DESTINATION ${MusE_SYNTHI_DIR}
)
install( FILES README.txt TODO