summaryrefslogtreecommitdiff
path: root/muse2/muse/mixer/CMakeLists.txt
diff options
context:
space:
mode:
authorOrcan Ogetbil <oget.fedora@gmail.com>2010-12-12 10:30:39 +0000
committerOrcan Ogetbil <oget.fedora@gmail.com>2010-12-12 10:30:39 +0000
commitcf0828dc76ddc11de107bc65ddada38d03404030 (patch)
tree2c56dd018886f2332330d4c98a46b05a23a3ab14 /muse2/muse/mixer/CMakeLists.txt
parenta4d6602deb9e55720659df425664c554be6e4a7a (diff)
Translations are now handled by cmake. Updated the Russian translation. Added -l flag to override system locale.
Diffstat (limited to 'muse2/muse/mixer/CMakeLists.txt')
-rw-r--r--muse2/muse/mixer/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/muse2/muse/mixer/CMakeLists.txt b/muse2/muse/mixer/CMakeLists.txt
index 979d57a5..2a85ff32 100644
--- a/muse2/muse/mixer/CMakeLists.txt
+++ b/muse2/muse/mixer/CMakeLists.txt
@@ -19,11 +19,11 @@
#=============================================================================
QT4_WRAP_CPP ( mixer_mocs amixer.h strip.h astrip.h mstrip.h meter.h rack.h panknob.h auxknob.h routedialog.h )
-QT4_WRAP_UI ( mixer_uis routedialogbase.ui )
-add_library ( mixer STATIC
- ${mixer_mocs}
- ${mixer_uis}
+file (GLOB UI_FILES routedialogbase.ui )
+QT4_WRAP_UI ( mixer_uis ${UI_FILES} )
+
+file (GLOB SOURCE_FILES
amixer.cpp
meter.cpp
rack.cpp
@@ -33,6 +33,14 @@ add_library ( mixer STATIC
strip.cpp astrip.cpp mstrip.cpp
)
+add_library ( mixer STATIC
+ ${SOURCE_FILES}
+ ${mixer_mocs}
+ ${mixer_uis}
+ )
+
+set (FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${SOURCE_FILES} ${UI_FILES} CACHE INTERNAL "")
+
set_target_properties ( mixer
PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h"
)