summaryrefslogtreecommitdiff
path: root/muse2/muse/mixer/CMakeLists.txt
diff options
context:
space:
mode:
authorOrcan Ogetbil <oget.fedora@gmail.com>2010-12-20 04:54:36 +0000
committerOrcan Ogetbil <oget.fedora@gmail.com>2010-12-20 04:54:36 +0000
commit673172e3ffb8e345b2bbfb6596ac3d79a1e17f14 (patch)
treed6535f36f0ff55b0f313d5e0aac8823c3fd98161 /muse2/muse/mixer/CMakeLists.txt
parentda484f0563218c2432ee4d6f2eb3ce8c7c298622 (diff)
Major cmake cleanup. Please see the ChangeLog.
Diffstat (limited to 'muse2/muse/mixer/CMakeLists.txt')
-rw-r--r--muse2/muse/mixer/CMakeLists.txt74
1 files changed, 60 insertions, 14 deletions
diff --git a/muse2/muse/mixer/CMakeLists.txt b/muse2/muse/mixer/CMakeLists.txt
index 52e08248..62a4ed11 100644
--- a/muse2/muse/mixer/CMakeLists.txt
+++ b/muse2/muse/mixer/CMakeLists.txt
@@ -18,38 +18,84 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#=============================================================================
-QT4_WRAP_CPP ( mixer_mocs amixer.h strip.h astrip.h mstrip.h meter.h rack.h panknob.h auxknob.h routedialog.h )
+##
+## Expand Qt macros in source files
+##
+QT4_WRAP_CPP ( mixer_mocs
+ amixer.h
+ astrip.h
+ auxknob.h
+ meter.h
+ mstrip.h
+ panknob.h
+ rack.h
+ routedialog.h
+ strip.h
+ )
-file (GLOB UI_FILES routedialogbase.ui )
-QT4_WRAP_UI ( mixer_uis ${UI_FILES} )
+##
+## UI files
+##
+file (GLOB mixer_ui_files
+ routedialogbase.ui
+ )
+QT4_WRAP_UI ( mixer_uis ${mixer_ui_files} )
-file (GLOB SOURCE_FILES
+##
+## List of source files to compile
+##
+file (GLOB mixer_source_files
amixer.cpp
+ astrip.cpp
+ auxknob.cpp
meter.cpp
- rack.cpp
+ mstrip.cpp
panknob.cpp
- auxknob.cpp
+ rack.cpp
routedialog.cpp
- strip.cpp astrip.cpp mstrip.cpp
+ strip.cpp
)
+##
+## Define target
+##
add_library ( mixer SHARED
- ${SOURCE_FILES}
+ ${mixer_source_files}
${mixer_mocs}
${mixer_uis}
)
-set (FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${SOURCE_FILES} ${UI_FILES} CACHE INTERNAL "")
+##
+## Append to the list of translations
+##
+set (FILES_TO_TRANSLATE
+ ${FILES_TO_TRANSLATE}
+ ${mixer_source_files}
+ ${mixer_ui_files}
+ CACHE INTERNAL ""
+ )
+
+##
+## Compilation flags and target name
+##
+set_target_properties ( mixer
+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -fPIC"
+ OUTPUT_NAME muse_mixer
+ )
+##
+## Linkage
+##
target_link_libraries ( mixer
${QT_LIBRARIES}
widgets
)
-install(TARGETS mixer DESTINATION ${MUSE_MODULES_DIR})
+##
+## Install location
+##
+install(TARGETS mixer
+ DESTINATION ${MusE_MODULES_DIR}
+ )
-set_target_properties ( mixer
- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -fPIC"
- OUTPUT_NAME muse_mixer
- )