summaryrefslogtreecommitdiff
path: root/muse2/muse/mixer/CMakeLists.txt
diff options
context:
space:
mode:
authorTim E. Real <termtech@rogers.com>2010-10-19 06:39:46 +0000
committerTim E. Real <termtech@rogers.com>2010-10-19 06:39:46 +0000
commit0490296a9bd979454042d0bc64f1f2c4c724a674 (patch)
treee5bd933bd47d372ea87daebc91c7f36280214328 /muse2/muse/mixer/CMakeLists.txt
parent7ee5592092707da25bf8cccfe3097f0a2a4a84de (diff)
See ChangeLog
Diffstat (limited to 'muse2/muse/mixer/CMakeLists.txt')
-rw-r--r--muse2/muse/mixer/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/muse2/muse/mixer/CMakeLists.txt b/muse2/muse/mixer/CMakeLists.txt
new file mode 100644
index 00000000..fb5c15cf
--- /dev/null
+++ b/muse2/muse/mixer/CMakeLists.txt
@@ -0,0 +1,40 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+QT4_WRAP_CPP ( mixer_mocs amixer.h strip.h astrip.h mstrip.h meter.h rack.h panknob.h auxknob.h routedialog.h )
+# QT4_WRAP_UI ( mixer_uis routedialogbase.ui )
+QT4_WRAP_UI3 ( mixer_uis routedialogbase.ui )
+
+add_library ( mixer STATIC
+ amixer.cpp
+ meter.cpp
+ rack.cpp
+ panknob.cpp
+ auxknob.cpp
+ routedialog.cpp
+ strip.cpp astrip.cpp mstrip.cpp
+ ${mixer_mocs}
+ ${mixer_uis}
+ )
+
+set_target_properties ( mixer
+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h"
+ )
+