summaryrefslogtreecommitdiff
path: root/muse2/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Jung <flo@windfisch.org>2011-10-08 13:47:24 +0000
committerFlorian Jung <flo@windfisch.org>2011-10-08 13:47:24 +0000
commita347445db32f51562aee5c6a786c312d1f612d2f (patch)
treeba3dc9a6e03eec2edf2c213b7f4d7e5e49903edc /muse2/CMakeLists.txt
parent375d6a53630f364c6560eb40255a8cc4c0496b8c (diff)
parent5367067f7a36dce8a362dcc000d41ac581bffdfe (diff)
merged namespace changes. HOPEFULLY the last one.
Diffstat (limited to 'muse2/CMakeLists.txt')
-rw-r--r--muse2/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/muse2/CMakeLists.txt b/muse2/CMakeLists.txt
index 9d438d0c..cfffaa8e 100644
--- a/muse2/CMakeLists.txt
+++ b/muse2/CMakeLists.txt
@@ -109,6 +109,7 @@ option ( ENABLE_DSSI "enable Disposable Soft Synth Interface (OSC also re
option ( ENABLE_VST "enable VST/win support" OFF)
option ( ENABLE_FLUID "enable fluidsynth softsynth plugins" ON)
option ( ENABLE_EXPERIMENTAL "enable building experimental features" OFF)
+option ( ENABLE_PYTHON "enable Python control support" OFF)
option ( UPDATE_TRANSLATIONS "Update source translation share/locale/*.ts files
(WARNING: This will modify the .ts files in the source tree!!)" OFF)
option ( MODULES_BUILD_STATIC "Build type of internal modules" OFF)
@@ -230,6 +231,17 @@ else (ENABLE_OSC)
endif (ENABLE_OSC)
##
+## check for python >= 2.4
+##
+
+if (ENABLE_PYTHON)
+ PKG_CHECK_MODULES(PYTHON python>=2.4)
+ if (PYTHON_FOUND)
+ set(PYTHON_SUPPORT ON)
+ endif (PYTHON_FOUND)
+endif (ENABLE_PYTHON)
+
+##
## check for dssi >= 0.9.0
##
@@ -400,6 +412,7 @@ add_custom_target(uninstall
## Show a summary of what we got
summary_add("Lash support" HAVE_LASH)
summary_add("OSC (Liblo) support" OSC_SUPPORT)
+summary_add("Python support" PYTHON_SUPPORT)
summary_add("DSSI support" DSSI_SUPPORT)
summary_add("VST support" VST_SUPPORT)
summary_add("Fluidsynth support" HAVE_FLUIDSYNTH)