summaryrefslogtreecommitdiff
path: root/muse2/synti/simpledrums2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/simpledrums2/CMakeLists.txt')
-rw-r--r--muse2/synti/simpledrums2/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/muse2/synti/simpledrums2/CMakeLists.txt b/muse2/synti/simpledrums2/CMakeLists.txt
index bf0c33d8..172ce616 100644
--- a/muse2/synti/simpledrums2/CMakeLists.txt
+++ b/muse2/synti/simpledrums2/CMakeLists.txt
@@ -74,9 +74,14 @@ set (FILES_TO_TRANSLATE
# libsimpledrums.so
# - use precompiled header files
#
+
+if ( x${CMAKE_BUILD_TYPE} STREQUAL xrelease )
+ SET(SIMPLEDRUMS_OPTFLAGS "-O6")
+endif ( x${CMAKE_BUILD_TYPE} STREQUAL xrelease )
+
set_target_properties ( simpledrums
PROPERTIES PREFIX ""
- COMPILE_FLAGS "-O6 -fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ COMPILE_FLAGS "${SIMPLEDRUMS_OPTFLAGS} -fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
)
##