summaryrefslogtreecommitdiff
path: root/muse2/synti/s1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/s1/CMakeLists.txt')
-rw-r--r--muse2/synti/s1/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/muse2/synti/s1/CMakeLists.txt b/muse2/synti/s1/CMakeLists.txt
index 890c6b12..7dffe905 100644
--- a/muse2/synti/s1/CMakeLists.txt
+++ b/muse2/synti/s1/CMakeLists.txt
@@ -25,7 +25,10 @@ add_library ( s1 SHARED s1.cpp )
# tell cmake to name target s1.so instead of
# libs1.so
#
-set_target_properties ( s1 PROPERTIES PREFIX "" )
+set_target_properties ( s1
+ PROPERTIES PREFIX ""
+ COMPILE_FLAGS "-fvisibility=hidden"
+ )
target_link_libraries(s1
synti