summaryrefslogtreecommitdiff
path: root/muse2/synti/fluidsynth/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/synti/fluidsynth/CMakeLists.txt')
-rw-r--r--muse2/synti/fluidsynth/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/muse2/synti/fluidsynth/CMakeLists.txt b/muse2/synti/fluidsynth/CMakeLists.txt
index cdb298e2..0c3e1b97 100644
--- a/muse2/synti/fluidsynth/CMakeLists.txt
+++ b/muse2/synti/fluidsynth/CMakeLists.txt
@@ -38,7 +38,7 @@ add_library ( fluidsynth SHARED
#
set_target_properties ( fluidsynth
PROPERTIES PREFIX ""
- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
+ COMPILE_FLAGS "-fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
LINK_FLAGS "${FLUIDSYN_LDFLAGS}" # "-lfluidsynth"
)