summaryrefslogtreecommitdiff
path: root/muse2/packaging/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/packaging/CMakeLists.txt')
-rw-r--r--muse2/packaging/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/muse2/packaging/CMakeLists.txt b/muse2/packaging/CMakeLists.txt
index e9b749b2..2582848a 100644
--- a/muse2/packaging/CMakeLists.txt
+++ b/muse2/packaging/CMakeLists.txt
@@ -18,10 +18,24 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#=============================================================================
+#
+# produce the .desktop file
+#
+configure_file (
+ muse.desktop.in
+ ${PROJECT_BINARY_DIR}/packaging/muse.desktop
+ )
+
+#
+# install the desktop and mime files
+#
install( FILES muse_icon.png
DESTINATION ${SHARE_INSTALL_PREFIX}/icons/hicolor/64x64/apps/
)
-install( FILES muse.desktop
+install( FILES ${PROJECT_BINARY_DIR}/packaging/muse.desktop
DESTINATION ${SHARE_INSTALL_PREFIX}/applications/
)
+install( FILES muse.xml
+ DESTINATION ${SHARE_INSTALL_PREFIX}/mime/packages/
+ )