summaryrefslogtreecommitdiff
path: root/muse2/muse/waveedit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/muse/waveedit/CMakeLists.txt')
-rw-r--r--muse2/muse/waveedit/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/muse2/muse/waveedit/CMakeLists.txt b/muse2/muse/waveedit/CMakeLists.txt
new file mode 100644
index 00000000..075aadff
--- /dev/null
+++ b/muse2/muse/waveedit/CMakeLists.txt
@@ -0,0 +1,42 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+QT4_WRAP_CPP ( waveedit_mocs
+ waveedit.h
+ waveview.h
+ editgain.h
+ )
+
+# QT4_WRAP_UI (waveedit_ui_headers
+QT4_WRAP_UI3 (waveedit_ui_headers
+ editgainbase.ui
+ )
+
+add_library ( waveedit STATIC
+ ${waveedit_ui_headers}
+ ${waveedit_mocs}
+ waveedit.cpp
+ waveview.cpp
+ editgain.cpp
+ )
+
+set_target_properties( waveedit
+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h"
+ )