summaryrefslogtreecommitdiff
path: root/muse2/muse/remote/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/muse/remote/CMakeLists.txt')
-rw-r--r--muse2/muse/remote/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/muse2/muse/remote/CMakeLists.txt b/muse2/muse/remote/CMakeLists.txt
new file mode 100644
index 00000000..bf04110d
--- /dev/null
+++ b/muse2/muse/remote/CMakeLists.txt
@@ -0,0 +1,21 @@
+#
+#
+#
+#
+
+include(${PROJECT_SOURCE_DIR}/pch.txt)
+
+set (remote_src
+ pyapi.cpp
+ )
+
+add_library(remote STATIC
+ ${remote_src}
+ ${PROJECT_BINARY_DIR}/all.h.pch
+ )
+
+set_source_files_properties(
+ pyapi.cpp
+ PROPERTIES COMPILE_FLAGS "-fPIC -include ${PROJECT_BINARY_DIR}/all.h -include ${PYTHON_INCLUDES} -DENABLE_PYTHON"
+ )
+