summaryrefslogtreecommitdiff
path: root/muse2/muse/liste/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/muse/liste/CMakeLists.txt')
-rw-r--r--muse2/muse/liste/CMakeLists.txt87
1 files changed, 55 insertions, 32 deletions
diff --git a/muse2/muse/liste/CMakeLists.txt b/muse2/muse/liste/CMakeLists.txt
index 72081478..4c0b61a4 100644
--- a/muse2/muse/liste/CMakeLists.txt
+++ b/muse2/muse/liste/CMakeLists.txt
@@ -18,57 +18,80 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#=============================================================================
+##
+## Expand Qt macros in source files
+##
QT4_WRAP_CPP ( liste_mocs
-# listedit.h
-# ctrllistedit.h
-# tracklistedit.h
-# partlistedit.h
-# ieventdialog.h
-
+ # listedit.h
+ # ctrllistedit.h
+ # tracklistedit.h
+ # partlistedit.h
+ # ieventdialog.h
+ editevent.h
listedit.h
- editevent.h
)
-file (GLOB UI_FILES
+##
+## UI files
+##
+file (GLOB liste_ui_files
editctrlbase.ui
)
+QT4_WRAP_UI ( liste_uis ${liste_ui_files} )
-QT4_WRAP_UI ( UIC
- ${UI_FILES}
- )
-
-file (GLOB SOURCE_FILES
-# listedit.cpp listedit.h
-# ctrllistedit.cpp ctrllistedit.h
-# partlistedit.cpp partlistedit.h
-# tracklistedit.cpp tracklistedit.h
-# ieventdialog.cpp ieventdialog.h
- listedit.cpp listedit.h
- editevent.cpp editevent.h
+##
+## List of source files to compile
+##
+file (GLOB liste_source_files
+ # listedit.cpp
+ # ctrllistedit.cpp
+ # partlistedit.cpp
+ # tracklistedit.cpp
+ # ieventdialog.cpp
+ editevent.cpp
+ listedit.cpp
)
+##
+## Define target
+##
add_library ( liste SHARED
- ${SOURCE_FILES}
+ ${liste_source_files}
${liste_mocs}
- ${liste_ui_headers}
- ${UIC}
+ ${liste_uis}
)
-set (FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${SOURCE_FILES} ${UI_FILES} CACHE INTERNAL "")
+##
+## Append to the list of translations
+##
+set (FILES_TO_TRANSLATE
+ ${FILES_TO_TRANSLATE}
+ ${liste_source_files}
+ ${liste_ui_files}
+ CACHE INTERNAL ""
+ )
-install(TARGETS liste DESTINATION ${MUSE_MODULES_DIR})
+##
+## Compilation flags and target name
+##
+set_target_properties( liste
+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -fPIC"
+ OUTPUT_NAME muse_liste
+ )
+##
+## Linkage
+##
target_link_libraries ( liste
${QT_LIBRARIES}
awl
widgets
)
-add_dependencies(liste widgets)
-
-set_target_properties( liste
- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -fPIC"
- OUTPUT_NAME muse_liste
- )
-
+##
+## Install location
+##
+install(TARGETS liste
+ DESTINATION ${MusE_MODULES_DIR}
+ )