summaryrefslogtreecommitdiff
path: root/muse2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'muse2/CMakeLists.txt')
-rw-r--r--muse2/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/muse2/CMakeLists.txt b/muse2/CMakeLists.txt
index 3d91aa7e..a10c7a6d 100644
--- a/muse2/CMakeLists.txt
+++ b/muse2/CMakeLists.txt
@@ -247,10 +247,12 @@ endif (ENABLE_OSC)
##
if (ENABLE_PYTHON)
- PKG_CHECK_MODULES(PYTHON python>=2.4)
- if (PYTHON_FOUND)
- set(PYTHON_SUPPORT ON)
- endif (PYTHON_FOUND)
+ include(FindPythonLibs)
+ if (PYTHONLIBS_FOUND)
+ if (NOT PYTHONLIBS_VERSION_STRING VERSION_LESS 2.4)
+ set(PYTHON_SUPPORT ON)
+ endif (NOT PYTHONLIBS_VERSION_STRING VERSION_LESS 2.4)
+ endif (PYTHONLIBS_FOUND)
endif (ENABLE_PYTHON)
##