summaryrefslogtreecommitdiff
path: root/attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt')
-rw-r--r--attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt b/attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt
deleted file mode 100644
index 1ac2652c..00000000
--- a/attic/muse_qt4_evolution/midiplugins/transform/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-#=============================================================================
-# MusE
-# Linux Music Editor
-# $Id:$
-#
-# Copyright (C) 2002-2006 by Werner Schweer and others
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#=============================================================================
-
-QT4_WRAP_CPP ( transform_mocs transform.h )
-QT4_WRAP_UI ( transform_uis transform.ui )
-
-add_library ( transform SHARED
- transform.cpp
- ${transform_mocs}
- ${transform_uis}
- )
-
-target_link_libraries( transform
- midiplugin
- ${QT_LIBRARIES}
- )
-
-# - tell cmake to name target transform.so instead of
-# libtransform.so
-# - use precompiled header files
-#
-set_target_properties ( transform
- PROPERTIES PREFIX ""
- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
- )
-
-install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/midiplugins/ transform )
-