summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt108
1 files changed, 108 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt b/attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt
new file mode 100644
index 00000000..c311b05a
--- /dev/null
+++ b/attic/muse2-oom/muse2/synti/deicsonze/CMakeLists.txt
@@ -0,0 +1,108 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+##
+## Expand Qt macros in source files
+##
+QT4_WRAP_CPP ( deicsonze_mocs
+ deicsonzegui.h
+ )
+
+##
+## UI files
+##
+file (GLOB deicsonze_ui_files
+ deicsonzegui.ui
+ )
+QT4_WRAP_UI ( deicsonze_uis ${deicsonze_ui_files} )
+
+##
+## Resource files
+##
+QT4_ADD_RESOURCES (deicsonze_qrc_files
+ deicsonze.qrc
+ )
+
+##
+## List of source files to compile
+##
+file (GLOB deicsonze_source_files
+ deicsonze.cpp
+ deicsonzepreset.cpp
+ deicsonzeplugin.cpp
+ deicsonzefilter.cpp
+ deicsonzegui.cpp
+ )
+
+##
+## Define target
+##
+add_library ( deicsonze SHARED
+ ${deicsonze_source_files}
+ ${deicsonze_mocs}
+ ${deicsonze_uis}
+ ${deicsonze_qrc_files}
+ )
+
+##
+## Append to the list of translations
+##
+set (FILES_TO_TRANSLATE
+ ${FILES_TO_TRANSLATE}
+ ${deicsonze_source_files}
+ ${deicsonze_ui_files}
+ CACHE INTERNAL ""
+ )
+
+##
+## Compilation flags and target name
+##
+# - tell cmake to name target deicsonze.so instead of
+# libdeicsonze.so
+# - use precompiled header files
+#
+set_target_properties ( deicsonze
+ PROPERTIES PREFIX ""
+ #COMPILE_FLAGS "-O2 -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ COMPILE_FLAGS "-fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ )
+
+##
+## Linkage
+##
+target_link_libraries(deicsonze
+ al
+ awl
+ synti
+ ${QT_LIBRARIES}
+ )
+
+##
+## Install location
+##
+install( TARGETS deicsonze
+ DESTINATION ${MusE_SYNTHI_DIR}
+ )
+install( FILES SutulaBank.dei
+ DESTINATION ${MusE_SHARE_DIR}/presets/deicsonze
+ )
+install( FILES README TODO
+ DESTINATION ${MusE_DOC_DIR}/deicsonze
+ )