summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/synti/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse2-oom/muse2/synti/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/synti/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/synti/CMakeLists.txt b/attic/muse2-oom/muse2/synti/CMakeLists.txt
new file mode 100644
index 00000000..73e6d349
--- /dev/null
+++ b/attic/muse2-oom/muse2/synti/CMakeLists.txt
@@ -0,0 +1,50 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+include_directories(
+ .
+ ${CMAKE_CURRENT_BINARY}
+ ${PROJECT_SOURCE_DIR}
+ ${PROJECT_SOURCE_DIR}/muse
+ ${PROJECT_SOURCE_DIR}/muse/widgets
+ ${PROJECT_SOURCE_DIR}/synti
+ )
+
+set (SubDirs
+ deicsonze
+ # deicsonze2
+ libsynti
+ organ
+ # simpledrums
+ simpledrums2
+ vam
+ )
+
+if (ENABLE_EXPERIMENTAL)
+ set (SubDirs ${SubDirs} s1 )
+endif (ENABLE_EXPERIMENTAL)
+
+if (HAVE_FLUIDSYNTH)
+ set (SubDirs ${SubDirs} fluid fluidsynth )
+endif (HAVE_FLUIDSYNTH)
+
+subdirs(${SubDirs})
+
+