summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt b/attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt
new file mode 100644
index 00000000..04ea864f
--- /dev/null
+++ b/attic/muse2-oom/muse2/plugins/doublechorus/CMakeLists.txt
@@ -0,0 +1,54 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+##
+## List of source files to compile
+##
+file (GLOB doublechorus_source_files
+ doublechorus.cpp
+ doublechorusmodel.cpp
+ simplechorusmodel.cpp
+ )
+
+##
+## Define target
+##
+add_library ( doublechorus SHARED
+ ${doublechorus_source_files}
+ )
+
+
+##
+## Compilation flags and target name
+##
+# tell cmake to name the target doublechorus.so instead of
+# libdoublechorus.so
+#
+set_target_properties (doublechorus
+ PROPERTIES PREFIX ""
+ #COMPILE_FLAGS "-O3"
+ )
+
+##
+## Install location
+##
+install( TARGETS doublechorus
+ DESTINATION ${MusE_PLUGINS_DIR}
+ )