summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/muse/remote/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse2-oom/muse2/muse/remote/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/muse/remote/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/muse/remote/CMakeLists.txt b/attic/muse2-oom/muse2/muse/remote/CMakeLists.txt
new file mode 100644
index 00000000..87ad9672
--- /dev/null
+++ b/attic/muse2-oom/muse2/muse/remote/CMakeLists.txt
@@ -0,0 +1,58 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+##
+## List of source files to compile
+##
+file (GLOB remote_source_files
+ pyapi.cpp
+ )
+
+##
+## Define target
+##
+add_library(remote SHARED
+ ${remote_source_files}
+ ${PROJECT_BINARY_DIR}/all.h.pch
+ )
+
+##
+## Append to the list of translations
+##
+set (FILES_TO_TRANSLATE
+ ${FILES_TO_TRANSLATE}
+ ${remote_source_files}
+ CACHE INTERNAL ""
+ )
+
+##
+## Compilation flags and target name
+##
+set_source_files_properties(
+ pyapi.cpp
+ PROPERTIES COMPILE_FLAGS "-fPIC -include ${PROJECT_BINARY_DIR}/all.h -include ${PYTHON_INCLUDES} -DENABLE_PYTHON"
+ )
+
+##
+## Install location
+##
+install(TARGETS remote
+ DESTINATION ${MusE_MODULES_DIR}
+ )