summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/muse/master/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'attic/muse2-oom/muse2/muse/master/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/muse/master/CMakeLists.txt81
1 files changed, 81 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/muse/master/CMakeLists.txt b/attic/muse2-oom/muse2/muse/master/CMakeLists.txt
new file mode 100644
index 00000000..bf2cebb7
--- /dev/null
+++ b/attic/muse2-oom/muse2/muse/master/CMakeLists.txt
@@ -0,0 +1,81 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+##
+## Expand Qt macros in source files
+##
+QT4_WRAP_CPP ( master_mocs
+ lmaster.h
+ masteredit.h
+ master.h
+ tscale.h
+ )
+
+##
+## List of source files to compile
+##
+file (GLOB master_source_files
+ lmaster.cpp
+ masteredit.cpp
+ master.cpp
+ tscale.cpp
+ )
+
+##
+## Define target
+##
+add_library ( master SHARED
+ ${master_source_files}
+ ${master_mocs}
+ )
+
+##
+## Append to the list of translations
+##
+set (FILES_TO_TRANSLATE
+ ${FILES_TO_TRANSLATE}
+ ${master_source_files}
+ CACHE INTERNAL ""
+ )
+
+##
+## Compilation flags and target name
+##
+set_target_properties( master
+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -fPIC"
+ OUTPUT_NAME muse_master
+ )
+
+##
+## Linkage
+##
+target_link_libraries ( master
+ ${QT_LIBRARIES}
+ al
+ awl
+ widgets
+ )
+
+##
+## Install location
+##
+install(TARGETS master
+ DESTINATION ${MusE_MODULES_DIR}
+ )