summaryrefslogtreecommitdiff
path: root/muse2/synti/fluid/CMakeLists.txt
diff options
context:
space:
mode:
authorTim E. Real <termtech@rogers.com>2010-11-01 08:36:22 +0000
committerTim E. Real <termtech@rogers.com>2010-11-01 08:36:22 +0000
commitbf32fe9882d7dd1dd6fbb88f39a42371063b6cd6 (patch)
tree57ce439a666b14632a186d859fd357134e6c414b /muse2/synti/fluid/CMakeLists.txt
parent4f767f96be2382c3f73a9619097a8cbabe3f7587 (diff)
All MESS plugins: compile with -fvisibility=hidden, fixes LADSPA plugins not appearing in list.
Added simpledrums2 (from muse_qt4_evolution).
Diffstat (limited to 'muse2/synti/fluid/CMakeLists.txt')
-rw-r--r--muse2/synti/fluid/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/muse2/synti/fluid/CMakeLists.txt b/muse2/synti/fluid/CMakeLists.txt
index 38184550..0007537f 100644
--- a/muse2/synti/fluid/CMakeLists.txt
+++ b/muse2/synti/fluid/CMakeLists.txt
@@ -38,7 +38,7 @@ add_library ( fluid SHARED
#
set_target_properties ( fluid
PROPERTIES PREFIX ""
- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
+ COMPILE_FLAGS "-fvisibility=hidden -include ${PROJECT_BINARY_DIR}/all-pic.h"
LINK_FLAGS "${FLUIDSYN_LDFLAGS}" # "-lfluidsynth"
)
target_link_libraries(fluid