summaryrefslogtreecommitdiff
path: root/muse2/muse/CMakeLists.txt
diff options
context:
space:
mode:
authorTim E. Real <termtech@rogers.com>2010-10-23 04:25:08 +0000
committerTim E. Real <termtech@rogers.com>2010-10-23 04:25:08 +0000
commit5ffe4bc73bd86027b2ce78ef804609df6dad03e9 (patch)
treedc13c63d0c8fb7c67d2ba3df52b3bad8bdd2d051 /muse2/muse/CMakeLists.txt
parenta568bd216d342740b78279b2a3797d2e2fbe0ab4 (diff)
See ChangeLog
Diffstat (limited to 'muse2/muse/CMakeLists.txt')
-rw-r--r--muse2/muse/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/muse2/muse/CMakeLists.txt b/muse2/muse/CMakeLists.txt
index fef848ad..192dc7e1 100644
--- a/muse2/muse/CMakeLists.txt
+++ b/muse2/muse/CMakeLists.txt
@@ -298,6 +298,7 @@ set_target_properties( muse
# PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h"
# PROPERTIES COMPILE_FLAGS "-Imidiedit -Iarranger -Iliste -Iwidgets -Imixer -Idriver -Iwaveedit -Implugins -Iinstruments -Iremote ${PYREM_CPP_FLAGS} -DSVNVERSION='\"${SVNVER}\"' -include ${PROJECT_BINARY_DIR}/all.h "
PROPERTIES COMPILE_FLAGS "${PYREM_CPP_FLAGS} -DINSTPREFIX='\"${CMAKE_INSTALL_PREFIX}\"' -DINSTLIBDIR='\"${LIBRARY_OUTPUT_DIRECTORY}\"' -DSVNVERSION='\"${SVNVER}\"' -include ${PROJECT_BINARY_DIR}/all.h "
+ OUTPUT_NAME muse2
)
target_link_libraries(muse
@@ -338,5 +339,5 @@ if(OSC_SUPPORT)
target_link_libraries(muse ${LIBLO_LIBRARIES})
endif(OSC_SUPPORT)
-install ( FILES ${PROJECT_BINARY_DIR}/muse/muse DESTINATION ${CMAKE_INSTALL_PREFIX}/bin/ RENAME muse2 )
+install ( TARGETS muse RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin/ )