summaryrefslogtreecommitdiff
path: root/muse2/muse/CMakeLists.txt
diff options
context:
space:
mode:
authorOrcan Ogetbil <oget.fedora@gmail.com>2011-10-07 04:23:17 +0000
committerOrcan Ogetbil <oget.fedora@gmail.com>2011-10-07 04:23:17 +0000
commit5367067f7a36dce8a362dcc000d41ac581bffdfe (patch)
tree0407ed68b4470749820b5bc6fb06d43388a83e97 /muse2/muse/CMakeLists.txt
parentf16b2037025918e32c5fd90527f76e1102e5ecb9 (diff)
clean residual namespace work. fix python control build.
Diffstat (limited to 'muse2/muse/CMakeLists.txt')
-rw-r--r--muse2/muse/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/muse2/muse/CMakeLists.txt b/muse2/muse/CMakeLists.txt
index b26100f9..187bd41e 100644
--- a/muse2/muse/CMakeLists.txt
+++ b/muse2/muse/CMakeLists.txt
@@ -43,11 +43,11 @@ set (SubDirs
widgets
)
-if (ENABLE_PYTHON)
- set ( PYREM_CPP_FLAGS "-DENABLE_PYTHON" )
- set ( PYLIBS ${PYTHON_LIB} remote)
+if (PYTHON_SUPPORT)
+ set ( REM_CPP_FLAGS "-DENABLE_PYTHON" )
+ set ( REM_LIB remote )
set ( SubDirs ${SubDirs} remote )
-endif (ENABLE_PYTHON)
+endif (PYTHON_SUPPORT)
subdirs (${SubDirs})
@@ -207,9 +207,9 @@ include_directories(
##
set_target_properties( core
# PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h"
- # PROPERTIES COMPILE_FLAGS "-Imidiedit -Iarranger -Iliste -Iwidgets -Imixer -Idriver -Iwaveedit -Implugins -Iinstruments -Iremote ${PYREM_CPP_FLAGS} -include ${PROJECT_BINARY_DIR}/all.h "
- # PROPERTIES COMPILE_FLAGS "${PYREM_CPP_FLAGS} -DINSTPREFIX='\"${CMAKE_INSTALL_PREFIX}\"' -DINSTLIBDIR='\"${LIBRARY_OUTPUT_DIRECTORY}\"' -include ${PROJECT_BINARY_DIR}/all.h "
- PROPERTIES COMPILE_FLAGS "${PYREM_CPP_FLAGS} -include ${PROJECT_BINARY_DIR}/all.h"
+ # PROPERTIES COMPILE_FLAGS "-Imidiedit -Iarranger -Iliste -Iwidgets -Imixer -Idriver -Iwaveedit -Implugins -Iinstruments -Iremote ${REM_CPP_FLAGS} -include ${PROJECT_BINARY_DIR}/all.h "
+ # PROPERTIES COMPILE_FLAGS "${REM_CPP_FLAGS} -DINSTPREFIX='\"${CMAKE_INSTALL_PREFIX}\"' -DINSTLIBDIR='\"${LIBRARY_OUTPUT_DIRECTORY}\"' -include ${PROJECT_BINARY_DIR}/all.h "
+ PROPERTIES COMPILE_FLAGS "${REM_CPP_FLAGS} -include ${PROJECT_BINARY_DIR}/all.h"
OUTPUT_NAME muse_core
)
set_target_properties( muse
@@ -246,7 +246,7 @@ target_link_libraries(core
${SNDFILE_LIBRARIES}
${SAMPLERATE_LIBRARIES}
${UUID_LIBRARIES}
- ${PYLIBS}
+ ${REM_LIB}
${FST_LIB}
dl
)