summaryrefslogtreecommitdiff
path: root/muse2/man/CMakeLists.txt
diff options
context:
space:
mode:
authorOrcan Ogetbil <oget.fedora@gmail.com>2010-12-27 00:52:36 +0000
committerOrcan Ogetbil <oget.fedora@gmail.com>2010-12-27 00:52:36 +0000
commit83898a46ade9f248fdae8703e97b3ea1bc03273d (patch)
tree3dafb97be064279b73fc8dceea848cd794e221db /muse2/man/CMakeLists.txt
parent8092776083f70a25b8615c7b8d6299e2daba8865 (diff)
Please see the ChangeLog
Diffstat (limited to 'muse2/man/CMakeLists.txt')
-rw-r--r--muse2/man/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/muse2/man/CMakeLists.txt b/muse2/man/CMakeLists.txt
new file mode 100644
index 00000000..a76a8e4a
--- /dev/null
+++ b/muse2/man/CMakeLists.txt
@@ -0,0 +1,37 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+#
+# produce the manpages
+#
+configure_file (
+ muse.1.in
+ ${PROJECT_BINARY_DIR}/man/${MusE_EXEC_NAME}.1
+ )
+configure_file (
+ grepmidi.1.in
+ ${PROJECT_BINARY_DIR}/man/grepmidi.1
+ )
+
+install( FILES
+ ${PROJECT_BINARY_DIR}/man/${MusE_EXEC_NAME}.1
+ ${PROJECT_BINARY_DIR}/man/grepmidi.1
+ DESTINATION ${SHARE_INSTALL_PREFIX}/man/man1/
+ )