summaryrefslogtreecommitdiff
path: root/muse2/al/CMakeLists.txt
diff options
context:
space:
mode:
authorTim E. Real <termtech@rogers.com>2010-10-19 06:39:46 +0000
committerTim E. Real <termtech@rogers.com>2010-10-19 06:39:46 +0000
commit0490296a9bd979454042d0bc64f1f2c4c724a674 (patch)
treee5bd933bd47d372ea87daebc91c7f36280214328 /muse2/al/CMakeLists.txt
parent7ee5592092707da25bf8cccfe3097f0a2a4a84de (diff)
See ChangeLog
Diffstat (limited to 'muse2/al/CMakeLists.txt')
-rw-r--r--muse2/al/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/muse2/al/CMakeLists.txt b/muse2/al/CMakeLists.txt
new file mode 100644
index 00000000..6075a399
--- /dev/null
+++ b/muse2/al/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+#
+#
+#
+
+include(${PROJECT_SOURCE_DIR}/pch.txt)
+
+set (al_src
+ al.cpp dsp.cpp
+ )
+
+if (USE_SSE)
+ set(al_src ${al_src} dspSSE.cpp dspXMM.cpp)
+endif (USE_SSE)
+
+add_library(al STATIC
+ ${al_src}
+ ${PROJECT_BINARY_DIR}/all.h.pch
+ )
+
+set_source_files_properties(
+ al.cpp dsp.cpp
+ dspXMM.cpp
+ PROPERTIES COMPILE_FLAGS "-fPIC -include ${PROJECT_BINARY_DIR}/all.h"
+ )
+
+set_source_files_properties( dspSSE.cpp
+ PROPERTIES COMPILE_FLAGS "-x assembler"
+ )
+