summaryrefslogtreecommitdiff
path: root/muse2/CMakeLists.txt
diff options
context:
space:
mode:
authorTim E. Real <termtech@rogers.com>2012-12-08 07:55:08 +0000
committerTim E. Real <termtech@rogers.com>2012-12-08 07:55:08 +0000
commit06ad98cc7ba5a9d282be31dc8dc65c447b7ada94 (patch)
tree9b92a253af54d055f5d167955073e66cdf0f6c7b /muse2/CMakeLists.txt
parentb5e36f27ecbb8c0a948aeeabe5698e86624f79a8 (diff)
Native VST fixes and changes.
Diffstat (limited to 'muse2/CMakeLists.txt')
-rw-r--r--muse2/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/muse2/CMakeLists.txt b/muse2/CMakeLists.txt
index 6f8d7817..b45b132e 100644
--- a/muse2/CMakeLists.txt
+++ b/muse2/CMakeLists.txt
@@ -37,7 +37,7 @@ if (NOT DEFINED LIB_SUFFIX)
endif (NOT DEFINED LIB_SUFFIX)
if (NOT DEFINED VST_HEADER_PATH)
- SET(VST_HEADER_PATH "${CMAKE_CURRENT_SOURCE_DIR}/vestige" CACHE PATH "Path to vst header files (aeffectx.h). Default is ./vestige. See ENABLE_VST_SDK.")
+ SET(VST_HEADER_PATH "${CMAKE_CURRENT_SOURCE_DIR}/vestige" CACHE PATH "Path to vst header files (aeffectx.h). Default is ./vestige. See ENABLE_VST_VESTIGE.")
endif (NOT DEFINED VST_HEADER_PATH)
message(" vst header path: " ${VST_HEADER_PATH} )
include_directories(${VST_HEADER_PATH})
@@ -123,8 +123,8 @@ option ( ENABLE_LASH "Enable LASH Audio Session Handler (or LADISH compat
option ( ENABLE_OSC "Enable Lightweight Open Sound Control (liblo) (DSSI also recommended)" ON)
option ( ENABLE_DSSI "Enable Disposable Soft Synth Interface (dssi) (OSC also recommended)" ON)
option ( ENABLE_VST "Enable VST/win support (deprecated)" OFF)
-option ( ENABLE_VST_NATIVE "Enable Native VST support (see ENABLE_VST_SDK and VST_HEADER_PATH)" ON)
-option ( ENABLE_VST_SDK "Enable VST SDK support (requires SDK, recommended for best results!)" OFF)
+option ( ENABLE_VST_NATIVE "Enable Native VST support (see ENABLE_VST_VESTIGE and VST_HEADER_PATH)" ON)
+option ( ENABLE_VST_VESTIGE "Set VST header type is Vestige" ON)
option ( ENABLE_FLUID "Enable fluidsynth softsynth plugins." ON)
option ( ENABLE_EXPERIMENTAL "Enable building experimental features." OFF)
option ( ENABLE_PYTHON "Enable Python control support." OFF)
@@ -340,11 +340,11 @@ endif (ENABLE_VST_NATIVE)
# find_file creates a cached variable. We don't want VST_HEADER_CHECK cached.
UNSET (VST_HEADER_CHECK CACHE)
-if (ENABLE_VST_SDK)
- SET (VST_SDK_SUPPORT TRUE)
-else (ENABLE_VST_SDK)
- SET (VST_SDK_SUPPORT FALSE)
-endif (ENABLE_VST_SDK)
+if (ENABLE_VST_VESTIGE)
+ SET (VST_VESTIGE_SUPPORT TRUE)
+else (ENABLE_VST_VESTIGE)
+ SET (VST_VESTIGE_SUPPORT FALSE)
+endif (ENABLE_VST_VESTIGE)
##
## TODO