summaryrefslogtreecommitdiff
path: root/muse2/CMakeLists.txt
diff options
context:
space:
mode:
authorOrcan Ogetbil <oget.fedora@gmail.com>2010-11-24 23:06:55 +0000
committerOrcan Ogetbil <oget.fedora@gmail.com>2010-11-24 23:06:55 +0000
commit443dde76876b66cb2e68d4f3ea65148a908f3cc2 (patch)
treefdd2e6541d73a273a7bf9f4617db6b2691c7cb9a /muse2/CMakeLists.txt
parent94e5d45e8703b2c03bc4b642ce236758dde76a1a (diff)
See ChangeLog
Diffstat (limited to 'muse2/CMakeLists.txt')
-rw-r--r--muse2/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/muse2/CMakeLists.txt b/muse2/CMakeLists.txt
index 374ae9c7..2624a2c3 100644
--- a/muse2/CMakeLists.txt
+++ b/muse2/CMakeLists.txt
@@ -79,6 +79,7 @@ option ( ENABLE_OSC "enable Open Sound Control (DSSI also recommended)"
option ( ENABLE_DSSI "enable Disposable Soft Synth Interface (OSC also recommended)" ON)
option ( ENABLE_VST "enable VST/win support" OFF)
option ( ENABLE_FLUID "enable fluidsynth softsynth plugins" ON)
+option ( ENABLE_EXPERIMENTAL "enable building experimental features" OFF)
##
## Just print a notice if this is OS X
@@ -269,6 +270,10 @@ else ( ENABLE_FLUID )
message("Fluidsynth disabled")
endif ( ENABLE_FLUID )
+if ( ENABLE_EXPERIMENTAL )
+ set(CMAKE_CXX_FLAGS -DBUILD_EXPERIMENTAL ${CMAKE_CXX_FLAGS})
+endif ( ENABLE_EXPERIMENTAL )
+
#
# produce config.h file
#
@@ -373,6 +378,7 @@ summary_add("OSC (Liblo) support" OSC_SUPPORT)
summary_add("DSSI support" DSSI_SUPPORT)
summary_add("VST support" VST_SUPPORT)
summary_add("Fluidsynth support" HAVE_FLUIDSYNTH)
+summary_add("Experimental features" ENABLE_EXPERIMENTAL)
summary_show()
# Make the user aware of what type they're building.