summaryrefslogtreecommitdiff
path: root/muse/awl/CMakeLists.txt
diff options
context:
space:
mode:
authorWerner Schweer <ws.seh.de>2006-06-14 13:32:45 +0000
committerWerner Schweer <ws.seh.de>2006-06-14 13:32:45 +0000
commitd67c6fc84c26abef0f3d2e7ab27db33261461bca (patch)
tree11a1b9956245c1df4ee78e6f0bafb6f982950f59 /muse/awl/CMakeLists.txt
parentdfa2357a3dcabaaffcc8c6767539fec738ecd8a9 (diff)
fix build of libawlplugin.so
Diffstat (limited to 'muse/awl/CMakeLists.txt')
-rw-r--r--muse/awl/CMakeLists.txt41
1 files changed, 37 insertions, 4 deletions
diff --git a/muse/awl/CMakeLists.txt b/muse/awl/CMakeLists.txt
index 3d8e1499..6af2bc2f 100644
--- a/muse/awl/CMakeLists.txt
+++ b/muse/awl/CMakeLists.txt
@@ -56,13 +56,46 @@ IF (APPLE)
message("Not yet able to build awlplugin under OS X.")
ELSE (APPLE)
- add_library ( awlplugin SHARED ${awl_src}
- awlplugin.cpp )
+ #
+ # build libawlplugin.so
+ #
+ QT4_WRAP_CPP (moc_awlplugin_headers
+ awlplugin.h
+ volknob.h knob.h aslider.h
+ slider.h volslider.h mslider.h
+ posedit.h poslabel.h
+ tempoedit.h tempolabel.h
+ combobox.h checkbox.h
+ panknob.h midipanknob.h
+ floatentry.h
+ )
+
+ add_library ( awlplugin SHARED
+ awlplugin.cpp
+ volknob.cpp knob.cpp aslider.cpp
+ slider.cpp volslider.cpp mslider.cpp
+ posedit.cpp poslabel.cpp
+ tempoedit.cpp tempolabel.cpp
+ combobox.cpp checkbox.cpp
+ panknob.cpp midipanknob.cpp
+ floatentry.cpp
+ ${moc_awlplugin_headers}
+ )
+
set_target_properties( awlplugin
- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
+ PROPERTIES COMPILE_FLAGS
+ "-D_GNU_SOURCE -D_REENTRANT -DHAVE_CONFIG_H -DQT_PLUGIN -DQT_SHARED -DQT_NO_DEBUG -include ${PROJECT_BINARY_DIR}/all-pic.h"
+ )
+ target_link_libraries( awlplugin
+ al pthread asound
)
install_targets ( /lib/${MusE_INSTALL_NAME}/designer/ awlplugin )
-ENDIF (APPLE)
+ add_executable( ltest ltest.cpp )
+ target_link_libraries ( ltest
+ awlplugin
+ ${QT_LIBRARIES}
+ )
+ENDIF (APPLE)