summaryrefslogtreecommitdiff
path: root/attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Jonsson <spamatica@gmail.com>2011-09-15 12:14:55 +0000
committerRobert Jonsson <spamatica@gmail.com>2011-09-15 12:14:55 +0000
commitb0546e5e7f7044019892543c6c82029db8d564a7 (patch)
tree1b96a6260900f3fbf3513fb48a5a72aa89052dc8 /attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt
parent583c73d1a07154d3d2672d65d8cce6495f490454 (diff)
moved attic to a branch of it's own
Diffstat (limited to 'attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt')
-rw-r--r--attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt47
1 files changed, 0 insertions, 47 deletions
diff --git a/attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt b/attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt
deleted file mode 100644
index 397ccf81..00000000
--- a/attic/muse_qt4_evolution/midiplugins/trigg/CMakeLists.txt
+++ /dev/null
@@ -1,47 +0,0 @@
-#=============================================================================
-# MusE
-# Linux Music Editor
-# $Id:$
-#
-# Copyright (C) 2002-2006 by Werner Schweer and others
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#=============================================================================
-
-QT4_WRAP_CPP ( trigg_mocs trigggui.h )
-QT4_WRAP_UI ( trigg_uis trigggui.ui )
-
-add_library ( trigg SHARED
- trigg.cpp
- trigggui.cpp
- trigggui.h
- ${trigg_mocs}
- ${trigg_uis}
- )
-
-target_link_libraries( trigg
- midiplugin awl
- ${QT_LIBRARIES}
- )
-
-# - tell cmake to name target name.so instead of
-# libname.so
-# - use precompiled header files
-#
-set_target_properties ( trigg
- PROPERTIES PREFIX ""
- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all-pic.h"
- )
-
-install_targets ( /${CMAKE_INSTALL_LIBDIR}/${MusE_INSTALL_NAME}/midiplugins/ trigg )
-