summaryrefslogtreecommitdiff
path: root/attic/muse2-oom/muse2/grepmidi/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Jonsson <spamatica@gmail.com>2011-03-07 19:01:11 +0000
committerRobert Jonsson <spamatica@gmail.com>2011-03-07 19:01:11 +0000
commite40fc849149dd97c248866a4a1d026dda5e57b62 (patch)
treeb12b358f3b3a0608001d30403358f8443118ec5f /attic/muse2-oom/muse2/grepmidi/CMakeLists.txt
parent1bd4f2e8d9745cabb667b043171cad22c8577768 (diff)
clean3
Diffstat (limited to 'attic/muse2-oom/muse2/grepmidi/CMakeLists.txt')
-rw-r--r--attic/muse2-oom/muse2/grepmidi/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/attic/muse2-oom/muse2/grepmidi/CMakeLists.txt b/attic/muse2-oom/muse2/grepmidi/CMakeLists.txt
new file mode 100644
index 00000000..ff607aca
--- /dev/null
+++ b/attic/muse2-oom/muse2/grepmidi/CMakeLists.txt
@@ -0,0 +1,40 @@
+#=============================================================================
+# MusE
+# Linux Music Editor
+# $Id:$
+#
+# Copyright (C) 2002-2006 by Werner Schweer and others
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#=============================================================================
+
+##
+## List of source files to compile
+##
+file (GLOB grepmidi_source_files
+ grepmidi.cpp
+ )
+
+##
+## Define target
+##
+add_executable ( grepmidi
+ ${grepmidi_source_files}
+ )
+
+##
+## Install location
+##
+install(TARGETS grepmidi
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+ )